LCD flickers/blurs

This is because the default theme of retropie (carbon) is really not adapted for small LCD. You can install “GBZ35” or “pixel TFT” themes which have bigger fonts, and better rendering on small LCD.

Still the Raspiboy use the composite signal of the raspiboy, so the picture will always be a little bit flickering. But this is mainly in emulation station main menu. In games it should not be much flickering. It’s because emulation station native resolution is for big TV and it does not scale down perfectly.

My LCD / Screen is Flipping, what is the reason?

This is because your RetroStone is out of battery.

When battery is getting low, the LED2 will turn on (see here LED status), then the LCD will start to go crazy (flip/blink …) then the RetroStone will shutdown.

So to solve this issue you just have to charge the battery! (note that you need a 5V 1.5A+ charger)

I want Return / Refund.

You can return in 14 days. Once we receive the item , we will refund you however you have to bear Shipping expense.

 

For return you can send it back to me at either of these address:

address 1: H312,Huachuangda building, Zone 42#
address 2: Baoan center
city: Shenzhen
zip code: 518101
country: China
TEL: +8615818744938

Or

“Pierre-Louis Boyer
60 rue Auber
94400
Vitry-sur-seine
FRANCE”

Please include in the boxe a paper with your order number and that it’s for a return. Please declare value as 20€ of the packet will be rejected.

Blue/white LCD

Is your RetroStone having this display first time you try to boot it?

1- Have you installed the operating system as explained in the tutorial?

RetroStone Tutorial

If yes but you still have the problem, have a look at the questions below and if it does not help, please open a ticket with the answer to the questions :

2- Are you using 8BCraft SD card?
3- Have you formated in FAT32 ? Formating in ExFAT for example will cause crashes/boot problems.
4- Are you waiting for ~10 seconds for LCD to get signal? First 10s it’s expected to have blue/white LCD before signal switch to LCD.
5 – Do you have something connected to USB when that happens? Some power hungry devices might crash the system.
6- With what software have you flashed the OS on the memory card? (did you not just copy paste the .img file on the memory card? This does not work.)

7 – Have you tried to clean microSD with diskpart, format in Fat32, flash again?

8- Is your battery low/empty (LED2 turns ON when low battery)? (LCD starts flipping when battery is low.)

9- Are you using a 5V 1.5A charger? Using a 5V 1A will result in battery charging slowly.

10- What version of Retrorangepi are you using? RetroStone version? SLIM, “SLIM PLUS”, or supremeretrostone version? Latest version?

11- Are you turning OFF from software before switching OFF the switch? RetroStone is a computer, if you hard-shutdown directly with the switch you might corrupt your OS. If you did switch off with switch rather than software and have problem since, please try clean SD card, format and reflash.

12- Have you tried to re-download the Retrorangepi image, just to make sure it wasn’t corrupted while downloading?

13- By chance do you have another microSD card to test if it’s the SD the problem?

14 – Have you tried with another computer? Some people report that it was the issue (probably the SD card reader that was making errors while writing or something like this)

Red line on my LCD

Your screen has a red line like on this one ?

This is just the temporary screen protector. You can remove this film by pilling the film by the green rectangle. Alternatively if you prefer the glossy style (without film it’s matte) you can keep the film, you can remove the red line by rubbing gently. And it’s usually possible to remove gently the green tab.

LCD is all white, what is the reason?

The full white LCD can have 2 reasons :

– either LCD is not connected correctly. If the black bar of the connector is not pushed down correctly.
– Either the LCD ribbon teared/broke.

Can you please check if the LCD ribbon has not broken/teared when you assembled the kit?

Also you can check our Trouble shooting faq here.